API Штрих-М чекопечати для конфигураций 1с7.7

Публикация № 1258685

Администрирование - Торговое оборудование - ККМ

Подключение Штрих-М Чекопечати  к конфигурации 1с7.7 на примере Штрих-М Торговое Предприятие Prof 4.13.05.

 

  1. Установка ПО

Установим Штрих-М Чекопечать Х.ХХ, если Windows 7 или выше будем устанавливать от имени администратора, обязательно устанавливать драйвера Атол и Штрих-М(по мануалу). Затем сделать запрос на ключ для привязки по ПК или ККТ, либо можно прбовать работать в режиме ДЕМО, сумма позиции в чеке не должна превышать 10р, а количество быть не более 1.

    1. Настройка ПО

Скопировать лицензию в корень программы чекопечати(обычно C:\Program Files\ShtrihOFD\) если она есть.

-Флаг «Печатать чек по макету(ShablonCheck.xml)» -печать чека идет по шаблону который задан в одноименном файле

-Пересчет чека без скидки с учетом округления – система пересчитывает чек с учетом скидки на позиции и округляет на весь чек

 -Вести лог-в папку «C:\Program Files\ShtrihOFD\Log» пишутся логи: errorFRДД_ММ_гггг.log – лог операций и ошибок по ККТ, MessageFileДД_ММ_гггг.log- лог операций по службе.

-Автоматическое снятие Z-отчета – при очередной операции регистрации, если прошло 24 часа система автоматически снимет отчет с гашением

-Проверять каталог на возможность записи –идет проверка возможно ли записывать в каталог чеков, этонужно для обратной связи, ошибочных или обработанных чеков.

  1. Доработка конфигурации

 

    1. Параметры для работы с Чекопечатью

Работать будем в обработке «НастройкаТорговогоОборудования». Добавим тип налогообложения, каталог в который будут сохраняться данные:

 

Процедура Выполнить:

…
//
	Настройка.Установить("КаталогЧекопечати",СокрЛП(УстКаталогЧекопечати)); 
	//
	ВыбиратьТипНалогооблажения = УстВыбиратьТипНалогооблажения.ПолучитьЗначение(УстВыбиратьТипНалогооблажения.ТекущаяСтрока());
	Настройка.Установить("ВыбиратьТипНалогооблажения",ВыбиратьТипНалогооблажения); 
	//
…

Процедура ПриОткрытии:

…
//
	УстДрайверФР.ДобавитьЗначение(3,"Штрих-М: Чекопечать"); 
	УстКаталогЧекопечати = КаталогЧекопечати;  
	//
	УстВыбиратьТипНалогооблажения.ДобавитьЗначение(0,"ОСН");
	УстВыбиратьТипНалогооблажения.ДобавитьЗначение(1,"УСН");
	УстВыбиратьТипНалогооблажения.ДобавитьЗначение(2,"УСН доход - расход");
	УстВыбиратьТипНалогооблажения.ДобавитьЗначение(3,"ЕНВД");
	УстВыбиратьТипНалогооблажения.ДобавитьЗначение(4,"Единый сельхоз налог");
	УстВыбиратьТипНалогооблажения.ДобавитьЗначение(5,"ПСН"); 
	Поз = УстВыбиратьТипНалогооблажения.НайтиЗначение(ВыбиратьТипНалогооблажения);
	Если Поз>0 Тогда
		УстВыбиратьТипНалогооблажения.ТекущаяСтрока(Поз);
	КонецЕсли;
	//
…

Добавим процедуру выбора каталога чекопечати:

 

Процедура _ВыбКаталога(Пар)
	Если Пар=1 Тогда
		ВыбКат=УстКаталогЧекопечати;
	КонецЕсли;
	Если ФС.ВыбратьКаталог(ВыбКат,"Выберите каталог файлов-чеков")>0 Тогда
		Если Пар=1 Тогда
			УстКаталогЧекопечати=ВыбКат;
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры

Процедура ВыборФР()

 

…
Если (ТекДрайверФР=2) ИЛИ (ТекДрайверФР=3) Тогда//
			РаботаСФР=1;МетодЧекопечати = Истина;
			УстШиринаЛенты.УдалитьВсе();
			УстШиринаЛенты.ДобавитьЗначение(0,"0");
			УстШиринаЛенты.ТекущаяСтрока(1);
…

Также изменим обработку «ПодключениеТорговогоОборудования». 

Процедура «Подкючить»:

 

…
//>>
	КаталогЧекопечати = Настройка.Получить("КаталогЧекопечати"); 
	ВыбиратьТипНалогооблажения = Настройка.Получить("ВыбиратьТипНалогооблажения"); 
	//<<
…
ИначеЕсли (ДрайверФР=2) ИЛИ (ДрайверФР=3) Тогда  //
			РаботаСФР=1; МетодЧекопечати =Истина;
…
    1. Изменения в глобальном модуле

В глобальный модуль добавим переменные:

 

//
Перем МетодЧекопечати Экспорт; 
Перем Истина Экспорт;
Перем Ложь Экспорт;  
Перем КаталогЧекопечати Экспорт;
Перем ВыбиратьТипНалогооблажения Экспорт;
//<< 

 

Процедура ПриНачалеРаботы, обнулим перменную МетодПечати

 

…
МетодЧекопечати =Ложь;//
…

 

    1. Обработка “ОбслуживаниеФр”

Для работы с чекопечатью нам нужно создавать файл чек  по протоколу для этого изменим процедуру “ПечататьЧек”:

 

…
//
	Если (ДрайверФР>0) И (МетодЧекопечати=Истина) Тогда//MI++>> 
		ИмяВременное = "checkTemp";
		Структура = ИнициализироватьСтруктуру("Заголовок");
		//---Заголовок чека--------------------------------// 
		Структура.ПризнакВозврата = Ложь;  
		Структура.Налогооблажение = ПолучитьТипНалогооблажения(ВыбиратьТипНалогооблажения);
		Если (Док.Вид()="Чек") Тогда
			Если (Док.ЧекНаВозврат=1) Тогда  
				Структура.ПризнакВозврата = Истина;
			КонецЕсли;
		КонецЕсли;             
		Если (Док.Вид()="РасходныйКассовый") Тогда
			Структура.ПризнакВозврата = Истина;
		КонецЕсли;  
		
		Если Док.Вид()="Чек" Тогда 
			Структура.НомерЧека = Док.НомерДок;
		Иначе
			Структура.НомерЧека = сокрлп(Док.НомерДок)
		КонецЕсли;  
		    
		Если ДобавитьВФайл(ИмяВременное,Структура,"head")=Ложь Тогда 
			Возврат;
		КонецЕсли;
		//-------------------------------------------------//
		Структура = ИнициализироватьСтруктуру("СтрокаЧека"); 
		//Если (Док.Вид()="РасходныйКассовый") Тогда 
		//Предупреждение("Тест пересчета");//Дебаг
		Если Док.Вид()="Чек" Тогда
			ПечататьСкидку = ПечататьЛиСкидку(Док);
			//			
			Док.ВыбратьСтроки();
			Пока (Док.ПолучитьСтроку()>0) Цикл
				Если Док.Товар.Выбран()=0 Тогда
					Продолжить;
				КонецЕсли;
				Если Док.Количество=0 Тогда
					Продолжить;
				КонецЕсли;
				Структура.Наименование	= СокрЛП(Док.Товар.НаимДляКассы); //СокрЛП(Док.Товар.Код)+":"+
				Структура.Количество	= Строка(Док.Количество*Док.Коэффициент);
				Структура.Цена			= Строка(Док.Цена);
				Структура.Секция		= Док.Товар.Секция;
				Структура.СуммаСоСкидкой= Строка(Док.СуммаБезСкидки);
				Структура.Налог 		= "4";//ПолучитьНалог(Док.Товар);//.СтавкаНДС-пока нет
				Если (Док.СкидкаНаПозицию<>0) Тогда
					Если Док.СкидкаНаПозицию>0 Тогда
						//Стр="Скидка "+строка(Док.СкидкаНаПозицию)+"%"; 
						Структура.СуммаСкидки = -(Док.СуммаБезСкидки-Док.Сумма);
					Иначе
						//Стр="Надбавка "+строка(-Док.СкидкаНаПозицию)+"%";
						Структура.СуммаСкидки = Док.СуммаБезСкидки-Док.Сумма;					
					КонецЕсли;					
				КонецЕсли; 
				Если (Док.Товар.ВидТовара=Перечисление.ВидыТоваров.Услуга) Тогда
					Структура.ПризнакПредметаРасчета = "4";//услуга
				Иначе
					Структура.ПризнакПредметаРасчета = "1";//товар
				КонецЕсли;
				//НДС? -пока нет
				Если ДобавитьВФайл(ИмяВременное,Структура,"str")=Ложь Тогда 
					Возврат;
				КонецЕсли;
			КонецЦикла;
			//------Подвал-------------------------------------//
			Если (Док.Скидка<>0) Тогда
				Если Док.Скидка>0 Тогда
					Стр="Скидка "+строка(Док.Скидка)+"%";
				Иначе
					Стр="Надбавка "+строка(-Док.Скидка)+"%";
				КонецЕсли; 
				СуммаСкидки = (Док.Итог("СуммаБезСкидки")-Док.Итог("Сумма"));
			КонецЕсли; 
			
			Структура = ИнициализироватьСтруктуру("ПодвалЧека"); 
			//Тут пишем название кредитной карты
			Если Док.ОплатаКредитом=1 Тогда 
				Если Док.КредКарта.Выбран()=1 Тогда   
					НазваниеКарты = СокрЛП(Док.КредКарта.Наименование);
					Структура.Сумма2 = Строка(Док.СуммаКредита);
				Иначе
					Структура.Сумма2 = Строка(Док.Итог("Сумма"));
				КонецЕсли;
			КонецЕсли;	 
			Если (Число(Структура.Сумма2)=0) Тогда  
				Если (Док.Получено=0) Тогда  
					Структура.Сумма1 = Строка(Док.Итог("Сумма"));
				Иначе
					Структура.Сумма1 = Строка(Док.Получено);
				КонецЕсли; 				
			КонецЕсли;
			Если ДобавитьВФайл(ИмяВременное,Структура,"end")=Ложь Тогда 
				Возврат;
			КонецЕсли;                           			
			//-------------------------------------------------//
			Док.ЧекПробитККМ=1;  
			//Запомним номер документа
			Док.НомерЧекаККМ=ВремНомерЧекаККМ; 
		ИначеЕсли ((Док.Вид()="ПриходныйКассовый") ИЛИ (Док.Вид()="РасходныйКассовый")) Тогда  
			ЕстьОснование = Ложь;  //Предупреждение("ТТТ");
			Док.ВыбратьСтроки();
			Пока Док.ПолучитьСтроку() = 1 Цикл
				Если ПустоеЗначение(Док.ДокументОснование1)=0 Тогда
					ЕстьОснование=Истина;
					ДокЧека = Док.ДокументОснование1;
					//
					ДокЧека.ВыбратьСтроки();
					Пока ДокЧека.ПолучитьСтроку() = 1 Цикл
						Если ДокЧека.Товар.Выбран()=0 Тогда
							Продолжить;
						КонецЕсли;
						Если ДокЧека.Количество=0 Тогда
							Продолжить;
						КонецЕсли;
						Структура.Наименование	= СокрЛП(ДокЧека.Товар.НаимДляКассы); //СокрЛП(Док.Товар.Код)+":"+
						Структура.Количество	= Строка(ДокЧека.Количество*ДокЧека.Коэффициент);
						Структура.Цена			= Строка(ДокЧека.РознЦена);
						Структура.Секция		= ДокЧека.Товар.Секция;
						//предупреждение("Дебаг");   
						Если (ДокЧека.Вид() = "ПриходнаяНакл") Тогда
							Структура.СуммаСоСкидкой= Строка(ДокЧека.СуммаРозн);
						Иначе	
							Структура.СуммаСоСкидкой= Строка(ДокЧека.СуммаРозн);
						КонецЕсли;	
						Структура.Налог 		= "4";//ПолучитьНалог(Док.Товар);//.СтавкаНДС-пока нет
						Если (ДокЧека.Вид() = "ПриходнаяНакл") Тогда 
							Структура.СуммаСкидки = 0;					
						Иначе	
							Если (ДокЧека.СкидкаНаПозицию<>0) Тогда
								Структура.СуммаСкидки = Строка(-ДокЧека.СуммаРозн+ДокЧека.СуммаРознСоСкидкой);//ДокЧека.СуммаСкидки;					
							КонецЕсли; 
						КонецЕсли;
						//
						Если (ДокЧека.Товар.ВидТовара=Перечисление.ВидыТоваров.Услуга) Тогда
							Структура.ПризнакПредметаРасчета = "4";//услуга
						Иначе
							Структура.ПризнакПредметаРасчета = "1";//товар
						КонецЕсли;  
						Если (ДокЧека.Вид() = "ПриходнаяНакл") Тогда
							Если (Док.Итог("Сумма")=0) Тогда
								СуммаДок = Док.СуммаДок;
							Иначе
								СуммаДок = Док.Итог("Сумма");
							КонецЕсли;
						КонецЕсли;
						
						//НДС? -пока нет
						Если ДобавитьВФайл(ИмяВременное,Структура,"str")=Ложь Тогда 
							Возврат;
						КонецЕсли;
					КонецЦикла;
				КонецЕсли;	
			КонецЦикла;   
			Если (ЕстьОснование=Ложь) Тогда 				
				//Распечатаем на чеке Основание и приложение   
				Если Док.Сотрудник.Выбран()=1 Тогда
					Стр=сокрлп(Док.ПриложениеСотрудника);
				Иначе
					Стр=сокрлп(Док.Приложение);
				КонецЕсли;  
				//-------------------------------------------------//  
				Если (Док.Итог("Сумма")=0) Тогда
					СуммаДок = Док.СуммаДок;
				Иначе
					СуммаДок = Док.Итог("Сумма");
				КонецЕсли;
				Структура = ИнициализироватьСтруктуру("СтрокаЧека");   
				Структура.Наименование	= СокрЛП(Стр); //СокрЛП(Док.Товар.Код)+":"+
				Структура.Количество	= Строка(1);
				Структура.Цена			= Строка(СуммаДок);
				Структура.Секция		= "1";
				Структура.СуммаСоСкидкой= Строка(СуммаДок);
				Структура.Налог 		= "4";//ПолучитьНалог(Док.Товар);//.СтавкаНДС-пока нет
				Структура.ПризнакПредметаРасчета = "4";//услуга
				Если ДобавитьВФайл(ИмяВременное,Структура,"str")=Ложь Тогда 
					Возврат;
				КонецЕсли;
			КонецЕсли; 
			//------Подвал-------------------------------------//
			Структура = ИнициализироватьСтруктуру("ПодвалЧека"); 
			Если ПустоеЗначение(СуммаДок)=0 Тогда
				Структура.Сумма1 = Строка(СуммаДок);
			Иначе     
				Если (Док.Итог("Сумма")=0) Тогда
					СуммаДок = Док.СуммаДок;
				Иначе
					СуммаДок = Док.Итог("Сумма");
				КонецЕсли;
				Структура.Сумма1 = Строка(СуммаДок);
			КонецЕсли;
			//
			Если ДобавитьВФайл(ИмяВременное,Структура,"end")=Ложь Тогда 
				Возврат;
			КонецЕсли;                           			
			//-------------------------------------------------//
			Док.ЧекПробитККМ=1;
			Док.НомерЧекаККМ=ВремНомерЧекаККМ;
		КонецЕсли;
		
		Возврат;
		//-------------------------------------------------//
…

 

Мы можем обрабатывать документы «Чек», «РасходноКассовый», «ПриходноКассовый», причем для ПКО и РКО будет учитывать документ основания если он есть для списка товаров/услуг.

    1. Обработка Отчеты

Для печати отчета с гашением изменим процедуру «Отчет»:

…
//>>
	Если (МетодЧекопечати=Истина) Тогда
		Пароль = 30;
		//Если ВвестиЧисло(Пароль,"Введите пароль",8,0) = 1 Тогда
		//КонецЕсли;  
		// вызов обработки обслуживания ККМ
		Расшифровка=СоздатьОбъект("СписокЗначений");		
		Расшифровка.ДобавитьЗначение(пароль,"пароль");
		Расшифровка.ДобавитьЗначение("ИмяОбработки","Отчет");
		
		Если Mode=3 Тогда//Z  
			Расшифровка.ДобавитьЗначение("ОтчетСГашением","Процесс");			
		ИначеЕсли Mode=2 Тогда	//X    
			Расшифровка.ДобавитьЗначение("ОтчетБезГашения","Процесс");	
		Иначе
			Возврат;
		КонецЕсли; 
		
		глРасшифровка = Расшифровка;
		глФлагРасшифровки = 1;
		ОткрытьФорму("Обработка.ОбслуживаниеФР#");
		глФлагРасшифровки = 0;
		глРасшифровка = 0;	
		Возврат;
	КонецЕсли;
	//<<
…

 

Примечание

Полное описание команд приложено в файле: «Полное описание команд.txt»

Последняя версия ссылка по Чекопечати:

3.2.01 –  Корректировка работы мультилицензии для ККТ Штрих-М.  Описание обратной связи для суммы в денежном ящике. Проверка ИНН при отправке на правильную длину. Корректировка мануала про тег в шаблоне “%AddT1%”. Флаг уникальности имени файл-чеков. Правка ошибок при работе с лицензией от предпоследней версии.

Скачать файлы

Наименование Файл Версия Размер
API Штрих-М Чекопечати  для конфигурации 1с7.7:

.txt 10,09Kb
01.07.20
1
.txt 10,09Kb 1 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. ЗС1 14.07.20 17:17 Сейчас в теме
Товар с маркировкой можно пробивать, чтобы в ОФД отразилась продажа либо возврат?
2. Ignatov_mu 32 15.07.20 10:20 Сейчас в теме
Да товар с маркировкой можно пробивать, просто не все ОФД показывают маркировку. Вам нужно уточнять у своего ОФД.
Оставьте свое сообщение

См. также

Печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54-ФЗ, поддержка изменений от 01/07/19). Для 1С (7.7 и 8 УФ, обычных форм) есть готовые обработки Промо

ККМ Фискальный регистратор Кассовые операции Оптовая торговля Розничная торговля Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Абонемент ($m)

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

7 стартмани

11.04.2017    64912    186    ah7777777    494    

Обработки обслуживания для "ВебЧек: Программный регистратор расчетных операций" (ПРРО)

Кассовые операции Розничная торговля ККМ Фискальный регистратор v7.7 v8 1cv8.cf 1cv7.md Украина Абонемент ($m)

ВебЧек: ПРРО - это программное решение для регистрации расчетных операций, создания электронных чеков на сервере фискальной службы.

1 стартмани

03.03.2020    2385    3    sergoff1    0    

ККМ в 1С 7.7 через Атол-вебсервер 10.Х

ККМ v77::ОУ 1С7:ТиС Фармацевтика, аптеки Россия Абонемент ($m)

Обработка для работы с Онлайн-ККМ в Е-Фарма 1.2.7 (1С 7.70.027) с помощью Атол-вебсервер 10.Х.

1 стартмани

17.12.2019    2365    5    Vlx    0    

Маркировка лекарств: разбор DataMatrix и формирование тега 1162

ККМ v7.7 1cv7.md Фармацевтика, аптеки Россия Абонемент ($m)

В при продаже маркированных лекарственных средств необходимо с упаковки считывать DataMatrix. Выделить из него GTIN и серийный номер упаковки. По алгоритму описанному https://честныйзнак.рф/upload/iblock/09e/09e9978505dad5ba4a8f814420ab20b7.pdf и https://xn--80ajghhoc2aj1c8b.xn--p1ai/upload/iblock/644/Format-zapisi-dannykh-o-vybytii-LP-v-FFD-v2_6.pdf сформировать тег 1162 и пробить чек на онлайн-ккм.

1 стартмани

19.11.2019    5700    21    Vlx    17    

Обработка для ККТ Атол 10.Х

ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Оптовая торговля, дистрибуция, логистика Россия БУ Абонемент ($m)

Обработка обслуживания ККТ Атол версии 10.Х в среде 1С 7.7 в ТиС релиз 7.70.998

10 стартмани

24.07.2019    3876    1    _s_y_a_    0    

1С 7.7: Обработка для печати чеков на ККМ ШТРИХ формата ФДД 1.05

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 1cv7.md Россия БУ Абонемент ($m)

Обработка позволяет печатать чеки формата ФДД 1.05 на кассовом аппарате ШТРИХ. Проверялась на версиях драйвера 4.14.721 - 749.

1 стартмани

03.04.2019    5513    4    user872794    1    

Штрих-М Онлайн-кассы для 1С 7.7 для новых прошивок с НДС20%

ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Россия НДС Абонемент ($m)

Обработка работает с новыми прошивками касс Штрих-М с НДС20%.

1 стартмани

20.02.2019    6993    16    fugitiveLDN    3    

Обработка обслуживания торгового оборудования. 1С: 7.7 ТиС

ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработка обслуживания для 1с 7.7 ТиС. Версия драйвера ККТ Атол 8.16.5.9221 Обработка предназначена для корректной передачи СНО при пробитии чека.

1 стартмани

18.01.2019    9623    21    artmaks1988    47    

Работа с пробитыми чеками по БД Атол

Разработка внешних компонент Кассовые операции ККМ Кассовые операции v7.7 1cv7.md Абонемент ($m)

Получение данных о пробитых чеках по ККМ Атол драйверов версии 8 на ОФД СБИС.

1 стартмани

13.07.2018    8526    1    pakko    7    

Поддержка Онлайн ККМ АТОЛ. Доработка ТиС 7.7 (Бюджетное решение) v 1.0

Кассовые операции ККМ Кассовые операции v77::ОУ 1С7:ТиС Россия УУ Абонемент ($m)

Релиз ТиС 7.70.987. Комплекс позволяет быстро и бюджетно подключить клиенту печать чеков на технике АТОЛ: АТОЛ 30Ф, АТОЛ 55Ф, АТОЛ 22Ф, АТОЛ 52Ф, АТОЛ 11Ф, АТОЛ 90Ф.

1 стартмани

09.07.2018    9705    7    zoeh    6    

Оболочка для работы с последними драйверами ККМ АТОЛ для 1С 7.7, 8.1

Разработка внешних компонент ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Абонемент ($m)

Внешняя компонента - оболочка для работы в среде 1С 7.7 или 1С 8.1 с последними версиями драйверов ККМ от АТОЛ. Поддерживаются драйвера x32 начиная с версии 9.11. Присутствует внешняя обработка для полноценной работы с данными драйверами (поддержка ревизий 2.0, 2.1, 2.2, поддержка протокола ОФД 1.0, 1.0.5, 1.1).

1 стартмани

09.08.2017    36240    292    asdfghgghjdhg    110    

54-ФЗ: Онлайн-касса (кассы). 1С 7.7 + Атол 55Ф ДТО8/10

ККМ Кассовые операции Кассовые операции v7.7 1cv7.md БУ Абонемент ($m)

Обработка ККМ-онлайн для нетиповой 1С:7.7 с печатью на несколько касс. Поддержка тегов 1227,1228. Поддержка версий драйверов ККТ: ДТО8, ДТО10 для Атол. Исходный код открыт.

2 стартмани

23.06.2017    19555    42    vakham    8    

Обработка подключения онлайн-кассы к 1С 7.7 (ПОЛУФАБРИКАТ)

ККМ Кассовые операции Кассовые операции v7.7 1С7:Бух Россия БУ Абонемент ($m)

Обработка обслуживания торгового оборудования для печати чеков ККМ. Протестирована на Конфигурации бухгалтерский учет (7.70.634) с кассой АТОЛ 30 Ф, Печать ПКО и РКО. Также работает на Торговля + Склад.

2 стартмани

31.05.2017    36248    108    Di_Denis    46    

Подключение Онлайн кассы Штрих М к 1С 7.7

Разработка внешних компонент ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 1cv7.md Абонемент ($m)

Подключение онлайн кассы Штрих М к любой конфигурации 1С 7.7. Показаны основные приемы работы с драйвером. Обработка представляет из себя набор готовых функций для встраивания в свою конфигурацию: ИнициализироватьФР(); ПодключитьФР(); ОтключитьФР(); ОткрытьСмену(); ЗакрытьСмену(); НапечататьЧек(); АннулироватьЧек(); СнятьХОтчет().

1 стартмани

08.05.2017    23969    75    crimeait    2    

Обработка для 1С ТиС 9.2 для работы с ККМ Offline под РМК Штрих-М Кассир 1.*\2.*\5.*

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработки предназначены для 1С: Предприятие 7.7 типовой конфигурации Торговля и Склад 9.2. Сделано несколько существенных изменений по отношению к стандартной обработке Off_spos. И доработана обработка "Загрузка ККМ Off-Line".

1 стартмани

28.08.2015    28165    32        4    

Подключение фискального регистратора Мини ФП54 через интернет бета

ККМ v7.7 1cv7.md Украина Абонемент ($m)

В продолжении темы подключения фискальных регистраторов через интернет http://infostart.ru/public/91545/.

1 стартмани

08.12.2014    20511    4    assa    4    

Печать чеков на Штрих-М-ФР-К в RDP (Удаленные филиалы)

Печатные формы документов Кассовые операции ККМ Кассовые операции v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Печать на Штрих-М-ФР-К через "Удаленный рабочий стол" RDP в филиалах. При печати через RDP в филиалах столкнулись с проблемой медленной печати и подключение Фискальных регистраторов к 1С. Эта обработка автоматически находит к какому порту подключен ФР и подключает его со всеми установленными настройками.

1 стартмани

28.02.2014    31808    18    Ronin    5    

Выгрузка-загрузка касс, персонала и дисконта.

Розничная торговля POS терминал ККМ Фискальный регистратор Розничная торговля v7.7 1С7:ТиС Розничная и сетевая торговля (FMCG) Абонемент ($m)

Данная обработка совмещает в себе выгрузку-загрузку (поддерживает различные режимы, как с документа, так и подбором), выгрузка дисконтных карт и персонала.

1 стартмани

23.07.2013    22510    8    kodinsklpz    11    

Внешняя компонента для работы с ККМ Искра "Прим-07К"

Разработка внешних компонент Кассовые операции ККМ Фискальный регистратор Кассовые операции v7.7 1cv7.md БУ Абонемент ($m)

Бесплатная внешняя компонента для 1С7.7, позволяющая работать с фискальными регистраторами производства Искра, такими как ПРИМ-07К, ПРИМ-08ТК и пр.

1 стартмани

18.06.2013    22617    27    sandyanf    3    

Печать идентификационного знака контрольно-кассовой техники для ЦТО

ККМ Кассовые операции Кассовые операции v7.7 1cv7.md Россия Абонемент ($m)

Печать идентификационного знака контрольно-кассовой техники для ЦТО.

1 стартмани

02.08.2012    17461    5    ta-so    6    

Банковский терминал и 1С7.7

ККМ v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Абонемент ($m)

1с7.7 и банковский терминал. Внешняя обработка обслуживания.

3 стартмани

21.05.2012    79876    490    avers007    45    

Отправка электронного письма в ККМ Frontol

Email ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработка облегчает процесс отправки электронного письма на ККМ Frontol.

1 стартмани

03.12.2011    22802    2    BorisBelov    3    

Дружба 1С Торговля и Склад 7.7 и Atol Frontol

ККМ Управленческие Розничная торговля Розничная торговля v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Несколько обработок на тему получения информации о продажах в 1С из Atol Frontol

1 стартмани

08.11.2011    18988    1    Denis_Viktorovich    5    

Переходим на летнее время (перевод времени на кассе (ФР))

Фискальный регистратор ККМ v77::ОУ 1cv7.md 1С7:ТиС Россия Абонемент ($m)

Уважаемые коллеги! Россия переходит на «летнее» время: стрелки часов в ночь на воскресенье, 28 марта, будут переводиться на час вперед, при этом в пяти регионах поменяются часовые пояса и их жителям переводить свои наручные и настенные «куранты» не придется.

1 стартмани

26.03.2010    19793    0    Tatitutu    4    

Штрих ФР-К обработка

ККМ Фискальный регистратор v77::ОУ Россия Абонемент ($m)

Обработка обслуживания ККМ Штрих ФР-К позволяет снимать X-отчёт, Z-Отчёт и проводить чеки с указанием наличной, безналичной и смешанной оплаты. Прилагается обработка для самого регистратора.

1 стартмани

15.11.2007    21520    30    sviaz    21    

Сверка Штрих-кодов в SMS и 1C на текущую дату

ККМ v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Проблемы были, товар не "бъётся" по кассе, хотя в базе всё есть. Вот и захотелось проверить что в SMS есть, а что в 1С. Сопоставить данные. Результаты позволили выявить "небъющийся товар". Т.к. Астор в новых релизах менял структуру базы SQL SMS, пришлось сделать 2 кнопки, для старого и нового формата sms.

1 стартмани

04.06.2007    11716    0    bnik    2